Unity Dashboard Tips

Most Unity Dashboard Games need an older Unity Web Plugin to work properly. The Unity 4.0+ plugin confuse the flip function on some Unity Dashboard Games… We advise you to use the latest stable Unity-3.5.7 version for Mac OS X 10.5+/10.6+/10.7+/10.8+ You can download the previous versions of Unity right here. As always you can use the(…)

Preview and Download ➜